We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

help j'arrive plus à installer Oxwall | Forum

blog-dom
blog-dom May 20
hello la team,depuis quelques temps je n'arrive plus a installé Oxwall,j'ai php7.2 voir plus à jour malgré cela ben non,or il n'y pas longtemps de cela j'avais installer un en mode démo et là non rien à faire!

voilà ce qui est dit



 


QuelquHosting Server Requirements

Your hosting account doesn't meet the following requirements:

  • mysql PHP extension not installed

Please correct these before you can proceed with Oxwall installation. Complete server requirements list and compatible hosting can be found at Oxwall.org/hostinge peut til me dire ou ça cloche!

d'avance merci !

The Forum post is edited by blog-dom May 21
blog-dom
blog-dom May 21
Hello j'ai résolu le souci pour l'installation !

j'ai du passé en version php 5.6.27 et l'installation s'est bien déroulée !

je viens de passer en version php 7.2.18 et cela fonction,donc voilà pour ceux qui veulent installer Oxwall .tout est expliqué !

Helios
Helios Jun 19
Bonjour


J'ai moi-même passé de la version 5.6 à 7.1 puis.2 et tout a continué a fonctionné. Par contre, si j'ai bien compris ton probleme, il est impossible d'installer directement sous PHP 7.2... il faut installer sous 5.6 et passer ensuite a 7.2. C'est bien cela?

Patricia Zorrilla Bcn

Et pourquoi cela s’intéresse-t-il à PHP 7.x ???

L'ensemble du système OxWall et les plugins sont conçus pour 5.6.

Si ce que vous recherchez, c'est la vitesse, vous devriez voir quels plugins ralentissent votre site ou si votre serveur ne convient pas, car en changeant la version de PHP, la vitesse augmente, vous avez besoin d'un chronomètre de laboratoire scientifique pour le détecter.

Par exemple, si vous installez ce plugin https://developers.oxwall.com/store/item/548

Toute page de profil peut prendre plusieurs secondes à s'afficher car elle appelle des sites Web externes.

Ce n’est pas seulement que vous obtenez un écran "qui a été installé correctement", mais aussi pour créer une plate-forme stable qui ne "se bloque" pas. Il pense que le système OxWall est basé sur de nombreux tableaux - trop nombreux - ce qui en fait un système très bien pensé pour sa souplesse et son optimisation, mais il est également intrinsèquement instable. Il suffit qu'un plug-in ne puisse pas afficher de données, un widget n'est plus disponible pour être affiché sur un site donné. Tout s'arrête et dit "erreur 500" et vous aurez besoin de plusieurs heures et de connaissances approfondies pour pouvoir trouver ce non-sens.

Je vois Oxwall comme un moteur qui offre des profils enregistrés avec votre login, mot de passe, thèmes graphiques utilisateur et tout cela, mais déjà résolu des plugins 99% de ce que votre site.

Oui, c'est bien que tout fonctionne plus, comme une lamborghini, mais lors de mon mariage, je préfère une limousine qui est jolie, ne m'écrase pas et ne m'emmène pas où je veux. Vous pouvez ignorer les milliers d'avis que vous obtenez en "mode débogage", mais si certains programmeurs qui connaissent tout cela plus que vous ne le prévenez, ce n'est pas à vous de l'ignorer.


blog-dom
blog-dom Jun 19
@Helios bonsoir, oui c'est cela d'abord avec  version 5.6 ensuite passer en version PHP 7.2 le mien est actuellement en ligne et je trouve aucun bug donc c'est tout bon!
Norias
Norias Jun 20
Patricia Zorrilla Bcn, you're right, but some people do not have choice of the php version their hosting provider is offering to them :/


Pour pouvoir installer oxwall sur une version de php7 il faut changer 'mysql' en 'mysqlnd' dans le fichier ow_install/files/requirements.txt

Si ca ne passe pas mais que vous êtes sûr.e d'avoir tout ce qu'il faut, il suffit de supprimer 'mysql'

 

The Forum post is edited by Norias Jun 20