We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Error newsfeed plugin | Forum

lisa
lisa Sep 8

hello sir

ok let me try these new commits from your link and update ow_libraires

and see results

i will update here on results and search forum for PHP7 issues if still not resolved


regards


lisa
lisa Sep 9

hello sir

i just want to update you and forum

i downloaded and fully instlled the git hub sofware link you gave me and this resovles the comment system not displaying comments after browser refresh and also it seems that its 7.x(3) php compatible and no parse errors should appear


but i found also a more efficient way to update an exisiting software webapp based on this platform it would be to run the PATCH

https://www.chamial.com/docs/faq/oxwall-to-chamial/patch-oxwall-to-chamial/


to get best results continue to update from ver build 1.8.4 all the way to 1.9.10

and this will now be up to date with php 7.3


regards

thank you sir

Lisa

The Forum post is edited by lisa Sep 9
lisa
lisa Sep 9

update

hello sir

it seems pictures and comments with pictures posted in a comment on the profile page still disappear after a refresh of the browser

i checkd that all options in the settings of the newsfeed plugin are checked but still same issue

must prbly be still code issue with php 7.x??

The Forum post is edited by lisa Sep 9
lisa
lisa Sep 9

i will check forum or post a new topic


regards

Lisa

thxz alot sir

it did some major improvements on comments in profile page


lisa
lisa Sep 9

update


i tested on localhost what i previously mentioned the link you provided to github full software code and the comments when posted with pics stay after browser refresh


so for me i will use this full version instead of patch or until patch resolves it


https://github.com/sosyallift/Chamial-Full





https://www.chamial.com/chamial-downloads/


ok thxz alot sir

Lisa

The Forum post is edited by lisa Sep 9
lisa
lisa Sep 11

UPDATE

it seems many host server companies give issues to this software

and so while i can run without any bugs on my localhost i still cannot find a live host than will not give me pictures issues where it doesnt stay on refresh and alos on other installs i cant even upload pics ..semms to be persmisons eroor but i put to 777 which is not secure so i change it back but it doesnt work anyway and so i was reading somewhere its mod secureserver setting mayvbe..so this is too complesx and so if anyone knows compatble host ..plz do reply ..i will just have to leave this software but thxz anyways


regards

Lisa

The Forum post is edited by lisa Sep 11
dave Leader
dave Sep 11
Lisa, i run my test site on namecheap and it works fine.  The only downside to namecheap is that they wont allow 1 min cron runs, the minimum is 5 min cron runs.   But if your just starting out that is no problem you can get the site going while you shop for another host.  I think they still have a deal where you can get the whole first year for 9.99, yes 10 bucks for the whole year and their support is great.  


Also it depends on what version your going to run, if you run the 1.8.4 version from oxwall then just choose php version 5.6.4 and then change it to 7.1 after its installed.  


However if you are going to run a third party oxwall install you will need to get with them for support. 


There must be something with your host because this is a easy software to install and get going. 

lisa
lisa Sep 12

hello thank you for the reply mr dave

i tried many fixes

1: on 1and1 (paid)

i have 1.8.4 oxwall and then used the patch method from this chamail website, and ran updates in the back end admin GUI all the way from 1.8,4 to 1.9.10

and switched to php 7.1 from 5.6 and it improved the errors , getting rid of parse errors and my comments on my profile page dont disapper after refresh..however if i post a comment with a pic the comment disappers after browser refresh


2. 1nad1 (paid)

i tried to install the full 1.9.10 chamail/oxwall software got 500 eror and tech support said their host not compatible


3. x10host (free)

i tried a full software chamail/oxwall but from github repo and run on php 7.1 but has many erros , all mainly with my profile page....pics dont load at all and so i cant check if when i post a comment with a pic on my profile if it will stay after a browser refresh


4. localhost ampps

i tried the 3rd software above and ALL works fine on php 7.1 and i was looking in the php extensins and i see many that x10host dont have and 1and1 does not have Cpanel and so its very limited to search php extesnions or mysql setting


i appreaciate your suggestion host, but i already pay for a 1year contract at 1and1 and so i am testing the sofatware on free hosts till i am happy and so i willtry 000freewebhostapp or infinty...


not sure what to do


lisa

The Forum post is edited by lisa Sep 12
lisa
lisa Sep 12

hello

also i have yet to use the cron.php file

but it seems to be somethin i should use

i dont have cpanel in 1and1 host

so i dont knw how to run it there

but i seen articles comenet and wiki and i beleive its doable on in cpanel

and x10host has cpanel


if you have straight forward steps plz display here if ok but if not its ok



lisa
lisa Sep 12

hello i refer this line in your comment


*******************

Also it depends on what version your going to run, if you run the 1.8.4 version from oxwall then just choose php version 5.6.4 and then change it to 7.1 after its installed.  

***************************8


i originally did install 1.8.4 ona 1and1 host and used php 5.6 but when i run php 7.1 i get comments not dispalying after refresh of the browser and also many parse errors


how di you get your software to work 1.8.4 ver on php 7.1?


ok thxz

lisa

dave Leader
dave Sep 12
First you need to start running the cron, oxwall depends on the cron running for many things, this might just solve most of your issues. 


If you dont have cpanel see here   


https://developers.oxwall.com/forum/topic/65420?&page=2

If you have cpanel just click on the cron icon on the main cpanel page 

then set it for every minute using the drop down menu.  


Then the command i use is  (you dont need the -0 option its not used anymore)


if your site is the public_html
php -q /home/username/public_html/ow_cron/run.php


remember i dont know anything about chamail, they made alot of changes so youll have to ask them if you use their product. 


The Forum post is edited by dave Sep 12
lisa
lisa Sep 12

ok thank you

i will work on the cron.php



lisa
lisa Sep 12

hello

i tried your link for cron steps without a cpanel but it stays on the same page as this one


https://developers.oxwall.com/forum/topic/65420?&page=2



lisa
lisa Sep 12

hello

with my main host 1and1

i just had to enter this

http://mysiteurl/ow_cron/run.php

i selected no authencation required

i dont know if this was the right choice

i know all my directires cant be access cuz of htaccess

but i saw its using GET

will this work?

i have it set to daily (that was the most)

and it says successfull

starst tomorrow morning


lisa

The Forum post is edited by lisa Sep 12
lisa
lisa Sep 12

hello

there was an option to validate my settings and run the cron now and so i selected that and it said succes and ran for 3 secs and said this cron job had no output


is this normal?

next cron will be tomorrow morning and every morning after


lisa

thxz if you know

apreciate it

lisa
lisa Sep 12

hello fourm

im pretty sure its working the setup i did for the cron.php

since i got an email for joining which is a test profile and i didnt join today

so i guess it went out to all the members becuz of the cron.php?


well anyways if you know

thxz

lisa

dave Leader
dave Sep 12
You cant do 1x a day, that wont work, oxwall uses cron to update just about everything going on with the site, posts, images, chats, everything.   Basically what you have told oxwall is that if someone posts something today i dont want to see it until tomorrow, thats not good.  Minimum i would go is 5 min, it should be 1 min but 5 will work until you get the site going and then you can figure out your host options. 


If they only have 1x per day, you need to change hosts. 

lisa
lisa Sep 12

hello and thank you for the reply

yes they only have 1 once  a day

i will consider your host and will try other free hosts to see results for now

i saw that x10host does have 1 minute cron

i set  it with that chamail software but still have issues

so i will upload the original 1.8.4 ox software and set the cron to 1 minute and run the web app 1st on php 5.6 and see what happens on php 7.1 and see


hope these steps i just outlined are correct

thxz for your reply agian

lisa

Steve
Steve Sep 12
The cron is within your control panel and has to do with PHP and/or Apache there is no settings for it in oxwall or chamial.
Oxwall Türkiye

WARNING...!  >> Dear lisa


Obviously what you need to do is explained in detail. But you persistently prefer to do wrong.

In my writing, you received clear help with the problem.


Lisa;

You are under the wrong topic of forum content.

The forum content contains PHP version content.

Please go to a forum page about PHP7 problems.

This is not a PHP version issue. You use it for purposes other than unnecessary. Then people who want to benefit from this title will be misleading.


Finally you get this help.

Please ask for help on the right topics.

You can't get different problems under a single title.

What you need to do;

Use PHP 5.6

Install Oxwalli

It will be setup without any problem at all.

Please read the previous answers for additional help.


Your unnecessary and unreasonable forum situation occurs. The main topic owner is waiting for help in this matter. Moving it to a different dimension prevents Marcus from getting help.


I hope you will show sensitivity and understand.


Pages: « 1 2 3 »