We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Avatar Problem | Forum

Topic location: Forum home » Oxwall International » Deutsch
Jochen
Jochen Sep 8
Hallo Alle, ich habe das folgende AVATAR / Profilphoto-Problem.

Klicke ich auf "Profilbild ändern"  wähle ich anschließend eine Datei aus und kann diese auch hochladen.
Nach Zuschneiden klicke ich auf "Auswahl anwenden" und es erscheint oben die rote Leiste mit dem Text "Profilbild konnte nicht zugeschnitten werden".  (siehe angehängte Dateien)

Gehe ich über "Profil bearbeiten"  und lade dort ein Profilphoto hoch, kann ich dieses auch sehen und zuschneiden und nach Klick auf "Auswahl übernehmen" sehe ich dann unten das kleine Profilbild. Aber:  Klicke ich abschließend auf "speichern" wird das Bild anschließend nicht im Profil angezeigt, obwohl per grünem Balken anzeigt wird "Profilbild aktualisiert".

Klicke ich während man das kleine Profilbild sieht mit der rechten Maustaste daraf, kann ich mir den Pfad zum Bild anzeigen lassen.
In diesem Fall lautet der Pfad: ....ow_userfiles/plugins/base/avatars/tmp/avatar_5d74abb9d5412.jpg?1567929123173

Dann bin ich per FTP auf meinen Server und siehe da, alle Avatars werden gespeichert in einem Unterordner vom Avatar-Ordner, einem temporären Ordner  "tmp"  wie schon im Link einige Zeilen vorher zu sehen ist.

Wo kann ich das ändern ? Offensichtlich werden Avatars im falschen Ordner gespeichert.

Zusätzlich habe ich mir auf der Seite wo man den Avatar abspeichern kann (vor klick auf "Speichern") den Quelltext angesehen und habe eine rote Zeile gesehen. Fehlt da etwa ein Leerzeichen zwischen save"name...  ? (siehe angehängte Dateien)
Welche Datei ist das ?  siehe Browser-Adresszeile mit einem roten Pfeil markiert im Screenshot

Kann Jemand helfen ?  Wäre super, vielen Dank im Voraus, vG, Jochen


.

Attachments:
  crop-errorJPG.JPG (69Kb)
  crop-error3.JPG (33Kb)
  sourcecode-save-avatar.JPG (178Kb)