We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Can't Upload Photos | Forum

Kelvin Nov 19 '14
I can help you find issues if you provide your site URL.
ross Team
ross Nov 19 '14
Read this post Josh: http://www.oxwall.org/forum/topic/28746?page=1 

Please do the search before posting anything on the forum. This will make easier for other community members to do the search if we keep the forum clean of duplicates. 

Bhardwaj Sinh
Bhardwaj Sinh May 14 '15
Hi everyone,

   I am suffering from same problems i am not able to upload photo on my oxwall powered site neither from albums nor from upload photos option thought users are able to upload their profile pictures. So please help me to sort out this problem my site is                                                                  


Thanks in anticipation,


ross Team
ross May 15 '15
Check you inbox, we already replied to you.
I logged in to your site. You have security module installed on your website. Contact your hosting provider support team and request to disable mod_security module or configure it properly.
And do the search on the forum before posting anything, this topic has already been discussed a bunch of times.
Stephan Toth
Stephan Toth Mar 1 '16
Hi, I got on to my service provider and they solved this problem.  I asked them to email me their solution related t CPanel security permissions which is reproduced below.

These are rules that got whitelisted and fixed your issue.
340147,  Potential Cross Site Scripting Attack
340148,  Potential Cross Site Scripting Attack
330039, Suspicious Unusual User Agent (python-requests).
340159, Generic SQL inline command protection

Many Thanks

Stacy Johnson
Technical Services Support Consultant
Zen Internet
T: 01706 902 009
W: http://www.zen.co.uk

This solution has worked for my site and I hope this helps other members and the Oxwall team to solve this problem.

Also, the video upload issues that people are suffering from is also a security issue similar to the one above with different permissions needing to be whitelisted.
ross Team
ross Mar 1 '16
Thanks for sharing Stephan, hope some community member find it useful 
Stephan Toth
Stephan Toth Mar 5 '16
Your welcome, glad to help out where I can. Steve
Stephan Toth
Stephan Toth Mar 7 '16
Some members may be having problems when trying to upload direct changes to text made in the Admin Languages page of their site.  This again is a permissions problem (same problem and solution as above) that only your hosting company can resolve.  Example: I wanted to change the welcome message on the Join form and on pressing send, I got an access error message from google.  The https://www.zen.co.uk/ CPanel team solved the problem in a couple of minutes - great customer service.
The Forum post is edited by Stephan Toth Mar 7 '16
Ronald Sep 19 '16
I uninstalled Photo plugin by accident and then reinstalled it. 

I also received the warning that i wasn't able to upload a photo because of a wrong extension (gif, jpg or png etc) or it was bigger than allowed by the server settings.  

I checked ow_pluginfiles and noticed that the photo folder wasn't there.  After i (re)created the folder i could upload photo's again.  :)

The Forum post is edited by Ronald Sep 19 '16
ross Team
ross Sep 20 '16
Thanks for letting us know and sharing the solution. 
RS Sep 11 '18
Hi, I never saw a fix for the "upload photo leads to blank page" error on this forum. Is Stephan's solution the correct one, or is this a new 1.8.4 thing?
Pages: « 1 2