We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Members friends Issue | Forum

Irena
Irena Aug 17
I've had a number of members approaching me about people disappearing from their friends list. 


Member adds someone as a friend it goes through, accept or they accept them, then like an hour or so later etc member click on the page of the person who accepted the friends request to leave a comment and it says add as friend. Neither of them clicking remove as friend.

Anyone got suggestions as to why the this issue is happening?

AppXprt
AppXprt Aug 17
Stale cache?
Irena
Irena Aug 17

Quote from AppXprt Stale cache?
Not sure tbh
Irena
Irena Aug 17

Quote from Sumate-RelajoSoft

Some time ago, a client had the same thing, as I remember he told me that his problem was solved after disconnecting cloudflare from his hosting, maybe he should look at that option, I'm not really sure if it is the problem, I just comment what I said that customer.

Have a nice day

I'd rather not disconnect it and i'm a she.
dave Team
dave Aug 17

Irena, you dont have to disconnect cloudflare, just be sure that you dont have any compression or js features enabled.   I dont remember the names of the features but they are meant to speed up the site, but they conflict with oxwall or your server so disable those.


Ill try to find the names...


one is called minify  and the other is rocket loader, disable them both


and caching level should be set to standard


let us know if the issue still exists afterwords.

The Forum post is edited by dave Aug 17
Sumate-RelajoSoft
Excuse me, don't listen to what I said, I don't think I understood your question correctly.
dave Team
dave Aug 17
Some things in cloudflare can break html and js for oxwall.
Irena
Irena Aug 17

Quote from dave

Irena, you dont have to disconnect cloudflare, just be sure that you dont have any compression or js features enabled.   I dont remember the names of the features but they are meant to speed up the site, but they conflict with oxwall or your server so disable those.


Ill try to find the names...


one is called minify  and the other is rocket loader, disable them both


and caching level should be set to standard


let us know if the issue still exists afterwords.

I will try that and wait to see if the issue persists. 
Irena
Irena Aug 18
This happened
dave Team
dave Aug 18

are you running the cloudflare plugin or are you running on a dedicated server and using cloudflare free plan for your DNS records?


also you dont seen to have a ssl cert for this site... thats not the issue but im curious why your running unprotected?

The Forum post is edited by dave Aug 18
Irena
Irena Aug 18

Are you running the cloudflare plugin or are you running on a dedicated server and using cloudflare free plan for your DNS records? : Using cloudflare free plan.


also you dont seen to have a ssl cert for this site... thats not the issue but im curious why your running unprotected?: there is a ssl cert

dave Team
dave Aug 18

ok thanks for the info....  i was not able to reach the site as the https was not working....


But regarding the issue, the only thing you can do is to consistantly check for errors, that means in the files and also in the console and copy and paste them so we can look into them and find out what is going on. 


If you want me to run through real quick and just give the site a once over (file wise) just pm the cpanel info and ill have a look to see if anything pops out. 


At the moment thats the best we can do until we are able to isolate the issue.


Is the site still down?

The Forum post is edited by dave Aug 18
Irena
Irena Aug 18

Quote from dave

ok thanks for the info....  i was not able to reach the site as the https was not working....


But regarding the issue, the only thing you can do is to consistantly check for errors, that means in the files and also in the console and copy and paste them so we can look into them and find out what is going on. 


If you want me to run through real quick and just give the site a once over (file wise) just pm the cpanel info and ill have a look to see if anything pops out. 


At the moment thats the best we can do until we are able to isolate the issue.


Is the site still down?

I got in touch with my hosting support and they told me that "There is a known service issue with cloudflare"  so i had to change the name servers to the ones they gave me. So, the site is propagating now. But i managed to get in and put it on maintenance mode via admin panel, just to cease the emails i'm getting from members about issues. Super stressful lol. I'm currently in cpanel checking. 

The site is up and down. It jumps between the error and actual site. 
dave Team
dave Aug 18
I remember when i had the same setup with cloudflare and my dedicated server that it took me a bit to get the DNS tweeked just right.  Are you using their protection for all your DNS records or just some of them?   I remember having issues until changing DNS protections.  Somewhere i have a screenshot of my DNS page for cloudflare as a guide for later.  Ill have to find it and let you compare yours. 
The Forum post is edited by dave Aug 18
Irena
Irena Aug 18
I haven't touched my dns since i initially set it all up.
Had no issues until recently.
dave Team
dave Aug 18

OK thats good...


What changed?


Sounds super simple, but have you tried running the db scan and fix from cpanel to see if the db might have errors?

The Forum post is edited by dave Aug 18
Irena
Irena Aug 18

Quote from dave

OK thats good...


What changed?


Sounds super simple, but have you tried running the db scan and fix from cpanel to see if the db might have errors?

That's the first thing i do whenever there's issues lol
I'll have to look through it to see.
I may of made a change and forgot.
Irena
Irena Aug 18
I'm no longer getting the cloudflare error. Site is up.
Since i did the changes with nameservers.
I'll keep watch for my initial issue and update you.
dave Team
dave Aug 19
Seems to be working, good to hear   :)