We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Can't Get Past Login Screen | Forum

Perky Bird
Perky Bird Aug 26 '21
I've had a problem that's persisted for a while now on my Oxwall site and I finally decided to make a post here. All the information should be in the screenshots. The problem showed up randomly, I didn't try to update Oxwall or install plugins. 


One more thing: My version is 1.8.3 because I couldn't install the latest version as it wasn't supported with my version of php, 7.4.16.

Chris_W
Chris_W Aug 26 '21
Your phone cuts off part of the error messages. post your error logs from the site root folder and from /ow_log/
Chris_W
Chris_W Aug 26 '21

There is a 1.8.7 version which should run on your PHP version. Just unzip the files over the existing files and then go to https://yoursite.com/ow_updates/

to complete the update.

The update does not include the ow_includes folder so your config.php file will not be overwritten.


This site is using 1.8.7 and runs on PHP 7.4 just fine: https://steveclean.biz/


It will also be worth updating Smarty in https://yoursite.com/ow_smarty/

The Forum post is edited by Chris_W Aug 26 '21
Attachments:
  oxwall-core-1.8.7.zip (3847Kb)
  smarty-master.zip (372Kb)
Perky Bird
Perky Bird Aug 26 '21
Because it does not have the ow_includes folder none of my settings or users will be lost, correct?


Also I installed my previous version using Installatron, does that change anything? I'm not familiar with unzipping files over existing files so I'll have to figure that out too.


Thank you for your help.


P.S. the portion of your comment that I was discussing is quoted below:
Quote from Chris_W

There is a 1.8.7 version which should run on your PHP version. Just unzip the files over the existing files and then go to https://yoursite.com/ow_updates/

to complete the update.

The update does not include the ow_includes folder so your config.php file will not be overwritten.




Chris_W
Chris_W Aug 27 '21

The ow_includes folder is where config.php is stored, this holds the database details and other information the software needs, so none of that will be overwritten.

Doing the update to 1.8.7 will not affect your users, and the method used to install the software shouldn't make any difference, the resulting install will be the same no mater how it was installed.


If you are using cPanell hosting, just use the file manager to upload the .zip file to the sites root folder and unzip it, you can then either delete the .zip file or leave it on the server, either is okay. Then point your web browser to https://yoursite.com/ow_updates/

Chris_W
Chris_W Aug 27 '21

If the above doesn't cure your problems then you could try the attached .zip file which is a custom file with some of the cures for Oxwall under php 1.74 included, it also has the latest version of Smarty.

Installation is the same, upload and unzip. Then point your web browser to https://yoursite.com/ow_updates/

Attachments:
  ow_custom_fixes.zip (7047Kb)