We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

File and Folder Permissions - a helpfull guide | Forum

dave Leader
dave Nov 7 '13

I thought this post might be helpful to someone at some point after an install or during a restore.  

 

Preface:  During a manual install of Oxwall (if you missed any file permissions) the script should take you through a process in order to verify that all the directories and files it needs to be writable are set as such.  And this process is where the information below was derrived from as i did a fresh install myself.  So with that said it is possible that not all items are mentioned on this list but you get the idea behind it i hope.

 

Issue: There are times as in doing a restore from backup that proper file permisions are not carried forward and passed to an from the backup media. What this means is that when you backup your files the permissions are normalized as directories 755 and files 644.  So you will need to reset any special permissions needed on files after a restore.  And this is the purpose of this post is to help you have (the ones i showed in a fresh install) handy so you can reset the permisions should you happen to restore a file or your script.

 

First the basic rule is this:

 

The install script will attempt to write to these folders:

 

Recursive means the folder and all folders and files within that folder, in essense everything, so then  non recursive means just do the item listed in specific.
 
  777 recursive permission folders:  (yes this means every file every folder, you can use filezilla to do it quickly, just right click on the folder, choose file attributes option, then type in 777, and they select the recursive option all folders and files. )  and kick back.. and relax as this will take awhile


  ow_pluginfiles/
  ow_userfiles/
  ow_static/

 

  777 non recursive permission:
  ow_smarty/template_c

 

That should cover it, 

Hope this helps :) 

 

Happy Oxwalling

 

 

The Forum post is edited by dave Apr 15 '20
Lech Sakhar
Lech Sakhar Jan 20 '14
ok. thank you. 
ricardo
ricardo Jan 28 '14
hi dave
and regarding the  htaccess files? should be 644 or 777?
thanks

The Forum post is edited by ricardo Jan 28 '14
samuel
samuel Feb 10 '14
I tried to do as you said, I put the folders acces 777 but I still can not upload photos
and no error message is displayed
 please i need help !!
The Forum post is edited by samuel Feb 10 '14
ross Team
ross Feb 10 '14
Samuel, please, create a post in bug reports and troubleshooting section. 
Wit
Wit Jun 4 '15

Good Day I have the same problem with permission and when I try to upload images, post create events, groups ect.


Please help

ross Team
ross Jun 4 '15
create a post in bug reports and troubleshooting section and elaborate the issue why exactly you can't. do you get any error or what? have you checked your firebug console for any errors?
Wit
Wit Jun 4 '15

Quote from ross create a post in bug reports and troubleshooting section and elaborate the issue why exactly you can't. do you get any error or what? have you checked your firebug console for any errors?


I did post in the bug forum but no reply from any no one

Oxwall Türkiye
Oxwall Türkiye Jan 29 '17

Member passwords can not be entered.

I could login with the password I obtained from the new password request form on the site.

The old password structure has collapsed.

It can be accessed by requesting a new password.


Dear dave would be pleased to be able to provide a help in this matter.

All member password algorithm collapsed.

The new password is requested and the entry is possible.

Old passwords are not available.


Can not add video Url withdrawals stopped


This problem was caused by a permission from the propoK plugin.

Developer mod_sec requested permission to be granted.

The manager asked for the required permits.

I sent a few e-mails on this subject, but Purusothaman Ramanujam did not report his permission.

The server administrator informed me that they were trying to provide the necessary permissions.

They wanted to check file permissions for control.

During the control of these permissions, I added the ow_incundle update and added the database information.


I can not add video now

Can not login with old member passwords.

Propoke plugin does not work.

Most of the cron senders are flagged as not finding an address.



My system is completely exploded

Please provide the required mod_sec directives.

What should I do for file and password problems.

New password entry from password request form

The Forum post is edited by Oxwall Türkiye Jan 29 '17
dave Leader
dave Jan 29 '17
The best thing to do is to restore a backup if you have it.  Do you have a backup from before this happened.
benjaminmcavoy
benjaminmcavoy Mar 17 '17
When I click on this photo I get this message......   CLients select user, and it goes to error 500..?  is there a simple fix for some who is not good at finding coding etc... thanks ben


dave Leader
dave Mar 19 '17
Yes turn on debug mode, check your error files, and make sure your server meets all of these specs on the right side of this page... http://www.oxwall.org/hosting


Do you know how to turn on debug mode and check error files?

benjaminmcavoy
benjaminmcavoy Mar 19 '17
Thanks Dave for the lightning fast response,  here is a debug I did, not sure what this Means   regards  Ben

message:Undefined offset: 1File:/home/sensingh/public_html/ow_system_plugins/base/bol/theme_service.phpLine:634
dave Leader
dave Mar 20 '17
That may not be the exact issue... what theme are you using?  Make sure you are using a default theme. 


Also disable all third party plugins and see if it still occures, if not then its a plugin that is causing this. 

benjaminmcavoy
benjaminmcavoy Mar 21 '17
Tks  I disable all plugins first, then loaded each plugins seperately,  that worked..!  yippeee  thaks so much.   would you know of a plugin that can upload videos direct from my PC instead of Youtue or other sources..?


dave Leader
dave Mar 21 '17
Yes this one https://developers.oxwall.com/store/item/1283


glad you got it sorted :)

Abu Road Escort
Lucknow Escort Service | < | > | Agra Escort Service | < | > | Aligarh Escort Service | < | > | Allahabad Escort Service | < | > | Ambedkar Nagar Escort Service | < | > | Auraiya Escort Service | < | > | Azamgarh Escort Service | < | > | Baghpat Escort Service | < | > | Bahraich Escort Service | < | > | Ballia Escort Service | < | > | Balrampur Escort Service | < | > | Banda Escort Service | < | > | Barabanki Escort Service | < | > | Bareilly Escort Service | < | > | Basti Escort Service | < | > | Bijnor Escort Service | < | > | Budaun Escort Service | < | > | Bulandshahar Escort Service | < | > | Chandauli Escort Service | < | > | Chitrakoot Escort Service | < | > | Deoria Escort Service | < | > | Etah Escort Service | < | > | Etawah Escort Service | < | > | Faizabad Escort Service | < | > | Farrukhabad Escort Service | < | > | Fatehpur Escort Service | < | > | Firozabad Escort Service | < | > | Gautam Buddha Nagar Escort Service | < | > | Ghaziabad Escort Service | < | > | Ghazipur Escort Service | < | > | Gonda Escort Service | < | > | Gorakhpur Escort Service | < | > | Hamirpur Escort Service | < | > | Hardoi Escort Service | < | > | Jalaun Escort Service | < | > | Jaunpur Escort Service | < | > | Jhansi Escort Service | < | > | Jyotiba Phule Nagar Escort Service | < | > | Kanpur Escort Service | < | > | Kannauj Escort Service | < | > | Kanshiram Nagar Escort Service | < | > | Kaushambi Escort Service | < | > | Kheri Escort Service | < | > | Kushinagar Escort Service | < | > | Lalitpur Escort Service | < | > | Mahamaya Nagar Escort Service | < | > | Maharajganj Escort Service | < | > | Mahoba Escort Service | < | > | Mainpuri Escort Service | < | > | Mathura Escort Service | < | > | Mau Escort Service | < | > | Meerut Escort Service | < | > | Mirzapur Escort Service | < | > | Moradabad Escort Service | < | > | Muzaffarnagar Escort Service | < | > | Pilibhit Escort Service | < | > | Pratapgarh Escort Service | < | > | Rae Bareli Escort Service | < | > | Ramabai Nagar Escort Service | < | > | Rampur Escort Service | < | > | Saharanpur Escort Service | < | > | Sant Kabir Nagar Escort Service | < | > | Sant Ravidas Nagar Escort Service | < | > | Shahjahanpur Escort Service | < | > | Shrawasti Escort Service | < | > | Siddharth Nagar Escort Service | < | > | Sitapur Escort Service | < | > | Sonbhadra Escort Service | < | > | Sultanpur Escort Service | < | > | Unnao Escort Service | < | > | Varanasi Escort Service | < | > |