We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Infinite loop when installing Oxwall on XAMPP | Forum

ross Team
ross Sep 22 '15

Add AllowOverride All after RewriteEngine On

See if the issue persists. 

Hybrid Sep 22 '15
That didn't work at all - adding that I couldn't even access the first page to try and install the software.  Here is what I see:

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500

Apache/2.4.16 (Win32) OpenSSL/1.0.1p PHP/5.6.12

The Forum post is edited by Hybrid Sep 22 '15
ross Team
ross Sep 22 '15
Hybrid, can you please try to install wamp and see if the issue with the installation persists?
Hybrid Sep 24 '15
Just got around to downloading and installing wamp - and once I got everything setup, it is still throwing that "Redirect Loop" error at me...

I even uninstalled xampp to give this a try - and even tried all possible solutions mentioned earlier - but nothing....

This Redirect Loop is a bitch :/

The very last thing I can think of is that I'm running a Windows 10 (OS) ... and maybe that is the reason why this isn't working - other than that, any other suggestions?

I prefer xampp over wamp!

ross Team
ross Sep 28 '15
We just tested fresh installation on Windows 10 on wamp, installation went well without any errors or redirect loops. Before doing the installation all we did is enabled rewrite_module in the apache settings. 
Hybrid Sep 28 '15
Could you test this on xampp (from Bitnami) on windows 10?  And if you get that working to let me know what you did?

The Forum post is edited by Hybrid Sep 28 '15
ross Team
ross Sep 29 '15
First of all bitnami does not have xampp stack

Please install usual xamp from here https://www.apachefriends.org/download.html

Hybrid Sep 29 '15
That is where I downloaded it from.

Also:Visit Bitnami XAMPP or click to see full list of add-ons and themes for XAMPP.https://bitnami.com/stack/xampp

Bitnami partnered with apachefriends to port the Bitnami library of applications to xampp.

I apologize in the post above this regarding me stating that "xampp (from Bitnami)"...I now realize that it is apachefriends but bitnami products/applications are included.

But yeah, going back to the topic at hand, the apachefriends.org website is where I initially downloaded xampp from.

Have you tried installing oxwall with it yet?  And if so, were you successful?  I'm still getting that redirect loop (again using Windows 10 here).

Hybrid Oct 8 '15
ross Team
ross Oct 12 '15
We cannot reproduce this on Xampp as well on Windows 10. See attachment screenshots 
  1.JPG (435Kb)
  2.JPG (197Kb)
  3.JPG (616Kb)
  4.jpg (783Kb)
Hybrid Oct 16 '15
This is just sooo bizarre...

I literally have no idea why this is happening...It occurs on Xampp and Wamp...sigh.

I've uninstalled and reinstalled these two applications like no other, configured shit left and right, changed ports up and down - good grief...

I still do not understand why this is only occurring with this software - wordpress and any other software I use works just fine...

ross Team
ross Oct 16 '15
Probably their .htaccess files conflicts with Oxwall's try to rename their .htaccess files and try again. 
Hybrid Oct 16 '15

Quote from ross Probably their .htaccess files conflicts with Oxwall's try to rename their .htaccess files and try again. 

What do you mean?

Do you mean change wordpress .htaccess files to something else and try again?  If so, that wouldn't matter - like I said, I've uninstalled and re-installed xampp and wamp countless times (including all previous data within the htdocs folder and the www folder) and tried so many times with a fresh install of oxwall with no other applications/software on it - just oxwall and I'm still encountering this issue.

Hybrid Oct 16 '15

I feel like we are not going to be able to solve this....And quite honestly, I'm tired of trying to figure this out...Feel free to close this up as "Unsolved - and gave up".

The Forum post is edited by Hybrid Oct 16 '15
ross Team
ross Oct 16 '15
I'm sorry in this case we cannot assist you as this is local server, on our side everything works fine as you can see from screenshots. 
Pages: « 1 2