We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Users staying online Forever! | Forum

Michael Leader
Michael Aug 8 '10
It seems that users are not being represented properly, seems they are online permenantly!

This was fixed in the wackwall deployment!
Emil Team
Emil Aug 9 '10
When you got permanently online users the problem may be with cron not executing. Please check. On WackWall there was a different problem but also related to cron.

Read http://docs.oxwall.org/install#cron
The Forum post is edited by Emil Aug 9 '10
Michael Leader
Michael Aug 9 '10
Ok. Will look (deeper)
Tbh I skipped the cron thing when installing

I'm bad!!

Let this be a lesson to others
Emil Team
Emil Aug 10 '10
No, you didn't skip it. We forgot to add it :) Sorry!
Michael Leader
Michael Aug 10 '10
There was be being all humble!!!
Does the cron job fix both email notifications AND the online thing?
If so, maybe log this as solved and attach to the email notification post I stuck up...
(Mark the email post as solved as well)
Emil Team
Emil Aug 10 '10
Yes, cron fixes both. Cool that it works for you now.
Michael Leader
Michael Aug 10 '10
Yup. Ty
carlos Sep 3 '10
What permissions I have to put the cron?

/home/themrx/public_html/web/ow_cron/run.php: line 1: ?php: No such file or directory
/home/themrx/public_html/web/ow_cron/run.php: line 3: /aquota.group: Permission denied
/home/themrx/public_html/web/ow_cron/run.php: line 4: access-logs: command not found
/home/themrx/public_html/web/ow_cron/run.php: line 5: syntax error near unexpected token `('
/home/themrx/public_html/web/ow_cron/run.php: line 5: ` * The contents of this file are subject to the Common Public Attribution License Version 1.0 (the “License”);'

I have it in a subdomain that brings problems?
Den Team
Den Sep 3 '10
Please, look my second reply on this topic.
I hope it'll help.
Juan Nov 9 '10
Hi, I had the same problem and after my host support tried a few times they came up with this and it worked: php -q /home/user/public_html/yourdomain/ow_cron/run.php ...This code is for a subdomain setup. Hope it works for you.
Den Team
Den Nov 10 '10
Thanks for suggestion Ruan.
Note: some hosting do not allow run php with with cron only with such command:
php -q /home/user/public_html/yourdomain/ow_cron/run.php

It is required to use full path to php installed, like this:
/usr/bin/php -q /home/user/public_html/yourdomain/ow_cron/run.php
Crewdog Sep 11 '11
I'm having a problem not expiring user sessions.

Question: How long does it take to expire session after user closes browser without logging off?

I have set up a cron job using cpanel and have verified by checking with hosting support (Host For Web) that cron job is running. They checked logs and confirmed. Since there is no output, the job does not send emails, but I added a second cron job to run the date command and send me email every minute and it works fine. So cron is running.

Host For Web level 2 support also confirmed that this job could be run every minute since it is low CPU usage, so no problems there. They checked cron configuration and told me it was fine. He added the -f option to the command (/usr/bin/php -f )

But even with this, when I test by opening a browser and logging in, then closing the browser without logging out, it still shows users logged in.

I have also tried calling the /ow_cron/run.php from the command (in SSH) but that doesn't clear it out.

I also tried suggestion to modify .htaccess file but not sure if I set up right. Please see this post. showing contents of .htaccess file.

Thanks in advance for any help!

The Forum post is edited by Crewdog Sep 12 '11
Den Team
Den Sep 13 '11
Would you run via SSH your full cron command? It should looks like /usr/local/bin/php -f /home/my_account/public_html/ow_cron/run.php
If you will not see any errors, then, in most cases your cron job was setup correctly. 

By default, script logged out members after 30 minutes of inactivity (with closed browser)
Crewdog Sep 13 '11
Thanks Addenster, I timed it last night and got 30 minutes as well so you confirmed it. 

It is working, and clearing inactive users off at 30 minutes.

If Admins want to set this value to a lower number for their sites, which source file(s) need to be modified?  The reason is below.

When hosting a community site with no chat plugin installed, 30 minutes default expire session is fine because users only email and communicate on message boards. So online status is not critical when users email or reply on message board because they will just see it next time they login.

But with chat plugin installed, user "online" status information is critical and must be current. When users see a friend or contact listed as "online" they open up a chat window thinking that friend is available to respond.  If they get no response they think that their friend is ignoring them.  Or if this happens many times that chat doesn't work (opening dead sessions), then users get frustrated and just resign from the site.


The Forum post is edited by Crewdog Sep 13 '11
Den Team
Den Nov 21 '11
Topic was moved from Bug reports and troubleshooting.