We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Important update - Video Instant Messenger | Forum

Skalfa LLC Partner
Skalfa LLC Dec 11 '15

As it's stated in our plugin description - our plugin works basing on the pretty new technology called WebRTC. For now this technology is supported only by the browsers/platforms listed here: https://en.wikipedia.org/wiki/WebRTC#Support


However, as recently Google announced, starting with version 47 Chrome does not longer support getUserMedia feature on non ssl domains. Along with Google Chrome other browsers are also going to provide access for WebRTC application to the web camera and microphone only via HTTPS. 

More information about this can be found here: https://sites.google.com/...-on-insecure-origins


Basing on the information above, we had to update our plugin with some changes to make it work through HTTPS smoothly. Now it's required to configure SSL certificate on the server to use the Video Chat plugin. 


If you have problems with the Video Chat plugin, first you need to perform the following steps:


- Update the Video Chat plugin to 9976 version (autoupdate should be available in the Admin Area);

- Replace the core files: ow_core/application.php and ow_core/mobile_application.php with the attached ones (these changes are already available in the Oxwall 1.8.1);

- Configure the SSL certificate (contact your hosting provider to get more information about the SSL certificate configuration);


If these steps do not solve the issue, please PM us and we will do our best to assist you.

The Forum post is edited by Skalfa LLC Feb 23 '16
Attachments:
  core_files.zip (12Kb)
JoshWho
JoshWho Mar 30 '16
Is this still current? as of right now I am trying to switch my site back to non ssl but with the new update i get a redirect loop with video calling.
Amos
Amos Mar 30 '16
I have a SSL Certificate Problem on my Server. doesn't work now.
I use ispconfig & debian 7
Skalfa LLC Partner
Skalfa LLC Apr 7 '16

JoshWho, the fact is that in the recent update Oxwall made some core changes related to the redirect from http protocol to https and vice versa. These changes force our customers to use the https protocol for the entire site in case they want the Video Instant Messenger worked correctly. If you do not want to move the entire site to https, we can suggest to apply small hot fix for now. This problem has already been reported to Oxwall team and they said they will fix it in the upcoming update. For now you have two options:


- change the site URL from http to https in the ow_includes/config.php file

- go to ow_core/application.php file, find this line:


$search[$index] = str_replace($matches[2][$index], str_replace("http:", "https:", $matches[2][$index])


and remove the colon for http and https, it should look like this:


$search[$index] = str_replace($matches[2][$index], str_replace("http", "https", $matches[2][$index])


If this does not solve your problem, please PM us your site URL and we will check into this issue.


Amos, to make the Video Instant Messenger work, you need to enable SSL at your server. The certificate should be valid (not self-signed).

Артём
Артём Jun 6 '16
Prompt these 2 files on replacement by version.1.8.0 will approach?
Skalfa LLC Partner
Skalfa LLC Jun 6 '16
Yes, these changes were given for the Oxwall 1.8.0 version. They have been already added into Oxwall 1.8.1. We suggest to update your site and the plugin to the latest version because there were done a lot of changes since Dec 11 '15 and this fix may not work anymore.
Juergen Schwarz
Juergen Schwarz Nov 11 '16
Hello,
Iam using plugin Video Chat (WebRTC) but ist not working anymore.
I have latest skydate Platform version: 1.8.4 (10800)and plugin is is properly configured.
Iam also using for video/calls the latest Chrome or Firefox browser.
But if I try to make a video/call from Adroid mobile to another Android mobile it shows
connecting..connecting..connecting and nothing more happend.
On the other mobile phone where I should receive the calling i get no connection, no ringing tone nothing. By the way, all user roles settings were configured correctly and enabled.
Any clue ?? What could be the issue?

Skalfa LLC Partner
Skalfa LLC Nov 13 '16
Hello Juergen,
As far as we've understood you are talking about the Mobile version opened via browser. Could you please specify what browser name and version you are using on your phones? Also, please specify whether you checked it at the Desktop? Does it work? Finally, have you configured SSL for your website?
The Forum post is edited by Skalfa LLC Nov 13 '16
Juergen Schwarz
Juergen Schwarz Nov 14 '16
Hello Skalfa support,
Yes, for testing Iam using 2 mobile phones Android with the latest Chrome or Firefox Browser. My Chrome version for mobile is : Chrome 54.0.2840.85
Also I have SSL configured for my website. Its running with SSL.
I also ckeced it at the Desktop version. But same result. 
If try to make a video/call from Adroid mobile to another Android mobile it shows
connecting..connecting..connecting and nothing more happend.
On the other mobile phone where I should receive the calling I get no connection, no ringing tone nothing. Please, see screenshot!
Need a solution to solve this issue?

Attachments:
  connecting.jpg (58Kb)
OW-Ghost
OW-Ghost Dec 1 '16
I have some customer complaint they can not use video call recently, i need check if i have same problems or not.
Skalfa LLC Partner
Skalfa LLC Dec 2 '16

Juergen, seems there are some errors and to tell the exact reason, we need to debug it. If you do not mind, we would ask you to PM your website domain, admin account and cPanel access details.


Marcus, please check it by yourself and let us know if you have this issue too.

Barrington
Barrington Mar 3 '18
Hi my name is Mr Campbell this plugin Video Chat (WebRTC) does not work at all , I tried all the steps you said to do , it made my site stop working . I had to restore my site . I would like to have my money back please.. its not right you guys are selling plug-ins that don't work no matter what you tell us to do. I paid $99 dollars with my PayPal account for something that will never work. 
This topic is sticky
You do not have permission to reply this topic