We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Internal Server Error [Solved] | Forum

Rahul Dec 24 '12
Try changing permission of index.php to 644
Alia Team
Alia Dec 26 '12
Salamoz, just wanted to follow up on your earlier post. Were you able to install the software?
Srinivasa Rao
Srinivasa Rao Jan 1 '13
actually where it is mod_rewrite is enabled? is cpanel or any
Purusothaman Ramanujam
Contact your hosting service provider to have it done if not.

If in localhost, you can easily do it yourself.
Valerie Jan 2 '13
I'm having the same problem, if I install using "Installatron" the script install fine, but then I have to manually upload the .htaccess to make the site work... but the "Installtron" metod have some issues, because it usually give me errors on files encoding.

I checked and I think my server (Hostgator) fully support all the system requirements, even has more features than the recommended ones, that's why I chosen them... But I can't find nothing on the error_log folder :/

The Forum post is edited by Valerie Jan 2 '13
Purusothaman Ramanujam
If you could explain in detail about your issues, I can try to solve it.
Valerie Jan 2 '13
I think it was something about file permission,  I changed the index.php chmod to 744 and now everything seems to works fine :D
manojkumar Feb 22 '13
Hi Valerie, Thank you soooo much... i was struggling with the same 500 problem for alomst 8 hours... i googled and tried all the suggestions given, but none worked... But atlast this simple chage of permission u have mentioned really worked.. thank you sooo much once again...
Hasiniaina Ragaby
Hasiniaina Ragaby Feb 27 '13
Solution for Error 500 - Internal server error

Insert the RewriteBase statement in your .htaccess.
Just after RewriteEngine on

RewriteEngine on
RewriteBase /

If you are in a subdir then RewriteBase /subdirectoryNameHere

I hope this helps someone.
Bobby K
Bobby K Mar 2 '13

Quote from Valerie 744

I'm on Hostgator, and Valerie's suggestion worked perfectly.  Thanks Valerie.
James Chambers
James Chambers May 5 '13
Okay, i am having this issue but not all the time... If i go to join with a new membership it goes through just fine going to join now or from the login dialog.  The issue happens when i use this in conjunction with contact importer it adds a "?code=longstringrandomlettersnumberssymbols" after the website.com/join   have tried enabling the debug features and it has not given any kind of debug information at all then i also tried changing the index.php from 644 to 744 and i get the same result.  any ideas?  i will be checking with contact importer as well to see if what they think.
Alia Team
Alia May 7 '13
James, what is your site URL?
Nathaniel Moikabi
Nathaniel Moikabi Jun 7 '13
I'm getting the same error at www.chatterclub.co .I am at the installation stage. My host is Godaddy.com and there are Oxwall sites hosted on the same server as mine that appear to be working fine.
Nathaniel Moikabi
Nathaniel Moikabi Jun 7 '13
My site uses the .co tld not .com


Thank you in advance for helping.

The Forum post is edited by Nathaniel Moikabi Jun 7 '13
Alia Team
Alia Jun 9 '13
Nathaniel Moikabi, check your server's error log.

Seems like you have uninstalled Oxwall from the http://chatterclub.co.
Nathaniel Moikabi
Nathaniel Moikabi Jun 11 '13
I have managed to install Oxwall by removing the .htaccess file, how will that affect the site.
ross Team
ross Jun 11 '13

Yes, it will affect the work of your website, as .htaccess file contains all the rules, regulations and processes of your website working procedures. Which means that .htaccess file contradicts the mod_rewrite settings on your hosting server, which is not good and means that your server is not properly configured for the software to run and be installed. Please, read this post: http://www.oxwall.org/forum/topic/4661

Nathaniel Moikabi
Nathaniel Moikabi Jun 12 '13
I have restored the .htaccess file and I'm now getting the internal server error. I have reported to my host who suggested that I change the permission to 644 but it does not work. I have reported this to them as well. Please help. 
ross Team
ross Jun 12 '13
Please, make sure that your server is configured according to our server requirements: 

  • Linux/Unix/Windows
  • Apache 2 or higher (with mod_rewrite module)
  • PHP 5.2.6 or higher with:
    • register_globals off
    • safe_mode off
    • suPHP off
    • suApache off
    • suhosin off
  • PHP modules:
    • PDO
    • DOM
    • mbstring
    • zip
    • zlib
    • ftp
    • json
  • MySQL 5.0 or higher
  • GD Library 2 with FreeType support
  • Mail server (SendMail, Exim or other)
  • Cron
pay special attention to the mod_rewrite settings. 

Keep us updated. 

ross Team
ross Jun 12 '13
if all server requirements are ok, check the error logs on your server
Pages: « 1 2 3 »