We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Avatar uploader and photo uploader will not load | Forum

Nathan May 14 '16

First I need to point out I have used the search and also done a forum search using google but I cant find a simple answer to this.

I have a problem when clicking on update avatar or when clicking upload photos it just turns the screen black with a black overlay with a progress bar and nothing ever loads to actually drag or choose an image the progress bar just keeps going and going and going.

In the console in both IE 11 and Chrome I get a java error of

In Internet Explorer 11

Unable to get property 'content' of undefined or null reference

In Chrome

Uncaught TypeError: Cannot read property 'content' of null

This error seems to be being caused by the below line in ow.js for both browsers tested

var contentHtml = markup.content, $contentHtml = $(contentHtml);

how do I fix the line so it loads the uploader where I can actually drag or choose my image file?

Thanks for any help and I have added a few screen shots.

  IE console 2.jpg (140Kb)
  IE console 1.jpg (125Kb)
  Chrome console 2.jpg (167Kb)
  Chrome console 1.jpg (137Kb)
Nathan May 14 '16
I forgot to mention that if you are wondering why in the pictures I have an avatar I uploaded that via the link on the Dashboard Page where the link actually opens the uploader where I can either drag or select my image to upload, It just does not work at all from the My Profile page, as for the photos plugin that will not work from either the Dashboard or the My Profile or Photo pages.
The Forum post is edited by Nathan May 14 '16
Darryl B Leader
Darryl B May 14 '16
Just gave mine a quick check, and everything works fine. Ross won't be back on until Monday. Have you tried disabling third party plugins, and/or switching themes to see if it still happens? If this doesn't work the next standard thing to do is to enable "Debug" in the config.php, and try the feature again with it enabled to see if there are errors. May as well run through the steps ahead of time.
Darryl B Leader
Darryl B May 14 '16
You may also want to look at this post. It appears to have been the same issue that you are experiencing.

Nathan May 15 '16

Quote from Darryl B You may also want to look at this post. It appears to have been the same issue that you are experiencing.

Thanks but that thread don't help really (like I said I searched the forum already using the search on the forum homepage and also searching the forum directly in google) although a very similar problem to mine my problem is under different circumstances my avatar as stated will work from the link on the Dashboard page but not on the Change Avatar link that comes up when you hover over the avatar area on the My Profile Page, also photo upload will not work full stop even if I try creating an album.

I have no third party plugins installed I just installed oxwall via softaculous and it is a standard install. I have even totally removed all oxwall plugins now as I thought there maybe some conflict but still the same problem on trying to Change Avatar from the My Profile page.

I have already tried all themes that come with Oxwall the same on them all.

I have uninstalled Oxwall 5 times both via Softaculous and manually installing and uninstalling, totally deleting the database on every new install and creating a new one with full privileges every time.

I have chmodded all the files and folders pointed out in the documentation and chmodded all recursively.

I do notice that on the Dashboard page the link to change the avatar has an ID in the actual anchor tag and this page works however on the My Profile page the link to change the avatar has the ID on the DIV instead of on the Anchor tag and this page does not work, I am starting to think that the ID in that DIV should actually reside inside the anchor tag because from the error in the console and from what I have found on google about the error it seems that it is not getting the ID passed so is returning a null, However I don't know enough about how oxwall is coded and what that DIV ID actually is or does to be able to test this theory out.

The Forum post is edited by Nathan May 15 '16
Darryl B Leader
Darryl B May 15 '16
Just a thought. Is the php version at 5.5? This was a requirement of the last release. I went ahead and set mine to 5.6 before the last update. If so, you could also try downloading the photo plugin from the store, uninstall it from your site, then upload the downloaded photo plugin. Just to make sure there wasn't something corrupted during the Softaculous install.
ross Team
ross May 16 '16
While installing the software via auto installer like Softaculuous, the server can fail. 

Can you please try to install the software manually and see if the issue persists, then we'll proceed with your issue?