We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Tried to Update Plugin but Site Has Crashed! | Forum

Blaire Aug 27 '18
Ah-hah! I had done this before with a different site. Haha, I feel silly I had no idea what it was called. Oh, oh. But thank you so much for guiding me very kindly!

So, yes, despite the 500 error this phpinfo screen did display quickly for me and I did remove it from appearing right away.

There are a few points that I do not know the answers to/do not see outright on the results. Namely, I do not see these outright and am not sure where I would go to find them based on what access I do have:
register_globals off:
safe_mode off:
suPHP off:
suApache off:
suhosin off:

Should I post my results in comparison to the requirements here for you to review?

One thing that sticks out to me (and maybe it's the issue here?) is that requirements page says:

MySQL from 5.0 to 5.6
Mine is set up as MySQL Version 10.0.35-MariaDB

I suppose that is a major leap out of the required range.

Perhaps this is the root cause of all issues? Is this something my host would likely be able to change or might it be best to find different hosting if this is, indeed, likely the problem?

I am on a monthly shared hosting plan for reasons like this--in case it just wasn't working out well so I wasn't locked in with a host until I knew for sure things were going to be reliable with a particular provider. (Horrible history with a previous host of other site taught me not to lock myself into long-term plans prior to really, thoroughly testing a host's reliability and responsiveness!)

I can private message you details, including the phpinfo page that I saved to my desktop and could attach I suppose, if you'd like more information. I just wasn't sure about posting it publicly here..?
dave Leader
dave Aug 27 '18
they are all listed on the report, now two of them may not show because they are deprecated anyway and no longer even supported now.  

Can you save that screen in pdf and zip it and send it to me in PM please...  if not ill look at my phpinfo and let you know where to look

dave Leader
dave Aug 27 '18
register_globals off:  no longer supported so it does not matter its not there

safe_mode off:  look under core on the report sql_safe_mode should be off

suPHP off:  search for it 
suApache off: search for it

suhosin off:  - is listed in alpha order on the report, just make sure its disabled or not listed. 

on the tab with the report press control f  which will bring up a search, and just search for part of the word and scroll through them 

Blaire Aug 28 '18
Hosting Requirements --

Linux/Unix/Windows: Check! Linux
Apache 2+: Version 2.4.33
mod_rewrite on: ? I do have RewriteEngine On within .htaccess so I'm assuming "yes"
mod_security on: I know this is enabled based on my cPanel access
mod_security strict configurations off: ? Few months back I had an issue and had to have ask host to do something with mod_security so it'd stop preventing some ad network from displaying on the site so I feel like perhaps they turned strict configurations off probably?

PHP 5.5 and 5.6: PHP version is 5.6.36
cURL on: On
fopen on: On
register_globals off: dave says it doesn't matter any longer
safe_mode off: sql.safe_mode: OFF
suPHP off: ctrl+F on phpinfo this does not exist on the form if I search for just suPHP
suApache off: ctrl+F on phpinfo this does not exist on the form if I search for just suApache
suhosin off: ctrl+F on phpinfo this does not exist on the form if I search for just suhosin

PHP modules
PDO: enabled (mysqul, sqlite)
DOM: enabled
mbstring: enabled as far as I can tell
zip: enabled
zlib: enabled
ftp: enabled
json: enabled (v 1.2.1)
php_openssl: OpenSSL says enabled

MySQL from 5.0 to 5.6:
MySQL Version 10.0.35-MariaDB

GD Library 2 with FreeType support:

This says GD is enabled (2.1.0 compatible) with FreeType enabled (v 2.3.11).

Mail server (SendMail, Exim or other):
I believe this works just based on my cPanel access to using mail. Never had an issue with mail exchanges while the site was up and functional.

I believe this is set up just based on my cPanel access. Cron matches what is described as appearing from this walkthrough: https://wiki.oxwall.com/install:cron
wget -q -O /dev/null http://www.yoursite.com/ow_cron/run.php
The Forum post is edited by Blaire Aug 28 '18
JB TECH Aug 28 '18
I don't know if this is still the problem, but the error about the invalid lang key means that a plugin's update file didn't attach the associated langs.zip with it, or didn't call to extract them. Delete the plugin files from ow_plugins, delete it's entry in the ow_plugins table in your database, delete any associate ow_plugins_static files with it, clear site cache and reinstall the latest version.
dave Leader
dave Aug 28 '18
+1 jake thanks...

Also for your cron you dont need the -O anymore its no longer used 

dave Leader
dave Aug 28 '18
ok send me your server details and your admin details in PM and ill take a look for you?
Blaire Aug 28 '18
I tried to do as instructed by Jake - JB TECH Oxwall Support. Though, I still have the 500 error, but it's possible I missed a step or a file somewhere? I went through it twice to make sure I removed what was suggested so I think I did as suggested in full but I want to say, "Hey, I'm a dummy human so it's possible I messed up!"

I'll PM you access details if you'd like to take a look, dave. No pressure! If you're busy or such then, please, no worries.
JB TECH Aug 28 '18
Also have you been able to get a hold of the plugin developer? By off chance it could be the main langs.file has an invalid or typo-d key. It happens to me all the time when I run test installations for updates on my plugins.
Darryl B Leader
Darryl B Aug 28 '18
Just an FYI. I ran the latest update of location maps, and didn't get this error. It appears that the update is due to Google Maps no longer being a free service. At any rate; with this I don't think it is an issue with the plugin since I didn't see a 500 error when updating. It could end up being a corrupted download, or install. Sometimes manually removing the plugin, and trying a fresh download, and install works.
Pages: « 1 2