We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Invalid FTP attributes! Provided user doesn't have permissions to overwrite files. | Forum

Alia Team
Alia Mar 19 '13
Webster, opening all whole site content to 777 permissions is not a good idea. Paul did this on demo site. We don't recommend doing this if your site is live.

We will be glad to check this issue for you if you provide us with access to your control panel and FTP.

Webster Molaudi
Webster Molaudi Mar 20 '13
Hi Aliia,

I managed to get it sorted :) thanks ...My hosting provider helped me apparently it was my login details that conflicted
Santiago
Santiago Nov 18 '13
I found the solution, maybe my english isnt perfect, but i do the follow:

- In the xampp control panel start filezilla.

- Go to Edit - Users.

- Create a User, and password (Dont forget), group memebership can be <none> no problem.

- In the left part go to shared folder, add and choose the main directory of xampp, in my case the installation was the default, so my directory is c:/xamp but y choose just c:/

- In the right part check all, read, write, delete, append, create, delete, list, +subdirs click ok

- Go to Edit (The upper menu) and clic in settings, the should appear a port in my case 21, clic ok and done


now fill the data in the oxwall ftp connection

server: localhost

user: YourUser

Paswword: YourPassword

Port: 21 (In my case)


the first time appear some warnings but y clic in the back button of the browser and i update the plugins without problems (Y)

Christer
Christer Nov 19 '13
I agree with Paul, I have this many times as I just building my sites and upload many plugins and this have happend more then once and It was always fixed with change permission to 777. And I did not open the hole site, I try one by one until I found were.
The Forum post is edited by Christer Nov 19 '13
James
James Nov 19 '13
Hi,


Further to my post (http://www.oxwall.org/forum/topic/14534), do you have idea which directory I would change to allow users to edit their own (and only their own) profile details?


Concerned about 777'ing folders and then not putting the permissions back properly on all the sub files / folders.


UPDATE- my issues has now been resolved. See http://www.oxwall.org/forum/topic/14534 if it helps anyone.


Thank you.

The Forum post is edited by James Nov 20 '13
Loceka
Loceka Jan 25 '14
I have the same problem with FTP and searched thoroughly.
After a bit of debug, I found that the function getPath(...) in file ow_utilities/ftp.php returned incoherent relative paths : the FTP root path was '/' in my case while the current path was '/home/myuser/www'. The relative paths returned by getPath(...) where always relative to $ftpRootDir regardless of the actual current dir.

I corrected it by returning the path specified in function args (often absolute but not always) and it works well for updating themes, at least (that's the only thing I've tried at the moment).

Still it bothers me a bit to discard the calculation that was done by that function and I wonder why it was performed. I guess the solution should use the ftp_pwd(...) value at some point but I haven't bothered searching deeper as returning the input path worked well at that point.

Could oxwall developers look into this please ?
Silvio
Silvio Feb 4 '14
Same problem... the ftp user i use is... root :) but it says i cannot write files.. then i tried to give 777 to all oxwall dirs... but still no solution.


tammy harris
tammy harris Mar 8 '14
i have just come to this problem myself on my server and looking at the problem 

in whm i have set some security options and has give me this problem now i have not yet fixed it but have found why i have this problem 

problem was before the whm settings the ftp user i set up in cpanel was using was uploading the files as owner root even though was not user root and root passwords

so everything i have uploaded with that ftp account has owner root
the setting in whm i set was disallow ftp by root so root pasword could never be used in ftp and get packet sniffed by a hacker

so to fix in may be a bit of a problem i have not find how to do it but i need change owner of every file and i am shore in command line there would be a easy way to do it but the black screen of death scares the crap out of me and i wont go near it  

 
   



Bem
Bem Mar 23 '14
problem solved,
create an ftp account in cpanel and give path to public_html
Scurra
Scurra May 2 '16
I have the same issue.

I have my own VPS, I don't use cpanel or anything similar.

I never had ftp server isntalled in the first place and all of a sudden

it started asking for FTP credentials while updating 'Forum' plugin.


I installed FTP server, allowed root user to login with ftp, chmod-ed recursively to 777

and I still get the stupid message.


This is pretty annoying.


Please help!

ross Team
ross May 3 '16
Please login to your server via Filezilla or similar software, try to edit any file. Please see whether you have the rights to do that with the access details you have. 
dave Leader
dave May 3 '16

^^^ what he said :) 



Here is what i do and never had this issue.. :)  


https://docs.oxwall.org/faq:how-to-add-new-ftp-account-to-update-add-plugins-and-themes


I have no idea who that contributor is on the bottom of the page, seems like a real funny guy though.. .:) 

The Forum post is edited by dave May 3 '16
Mark
Mark Oct 12 '16
So I've done everything above stated still getting the same error which folder do I need to change the permissions to 777? that's the million dollar question that NO one seems to be answering!, obviously not ALL of them.. So which one is it?
Darryl B Leader
Darryl B Oct 12 '16
Check this post to see if it helps.

https://developers.oxwall.com/forum/topic/14334
Pages: « 1 2